ERROR AL COMPILAR EN V. 2.1.0 PROGRAMAS CREADOS EN V. 2.0.9 (SOLUCIONADO)

  • 2 Respuestas
  • 105 Vistas

gabrielmc78

  • Novato
  • *
  • Mensajes: 9
Hola estimado. Actualice a STX version 2.1.0 y, al compilar programas creados con la 2.0.9, se queda indefinidamente al 50% de la compilacion (aproximadamente). No arroja mensaje de error pero luego de horas debo cancelar, no hay forma de compilar. Si vuelvo a la version 2.0.9, funciona perfecto
« Última Modificación: agosto 11, 2021, 17:28:17 pm por Soporte »

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 2221
  • Soporte Técnico
Re:ERROR AL COMPILAR EN V. 2.1.0 PROGRAMAS CREADOS EN V. 2.0.9
« Respuesta #1 : julio 26, 2021, 10:24:10 am »
Buenos días Gabriel,

Tenés razón, acabo de probar, solo ocurre para el modelo STX8140 cuando en el proyecto Ladder se utiliza el componente MbRtuClSetRxEvent. Es un error interno en el software.

En estos días subo StxLadder 2.1.1 con la corrección y te aviso por este medio.

Mientras tanto, no actualices el firmware del dispositivo a la última versión, ya que el mismo requiere StxLadder 2.1.0, el cual te da el problema mencionado.

Saludos!
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 2221
  • Soporte Técnico
Re:ERROR AL COMPILAR EN V. 2.1.0 PROGRAMAS CREADOS EN V. 2.0.9
« Respuesta #2 : agosto 11, 2021, 17:27:59 pm »
Buenas tardes Gabriel,

Ya se encuentra disponible para descargar StxLadder 2.1.1 que arregla el error mencionado.

Esta versión de StxLadder requiere también que actualices el firmware del STX8140 a la versión V225 o superior:

www.slicetex.com/hw/stx8140/soft.php

Es decir, al instalar StxLadder, debés actualizar el firmware del STX8140, para que luego te deje transferir un programa al PLC.

Saludos!
« Última Modificación: agosto 11, 2021, 17:29:34 pm por Soporte »
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com