AYUDA: ruido eléctrico en entradas digitales? (SOLUCIONADO)

  • 16 Respuestas
  • 386 Vistas

guille

  • Aprendiz
  • **
  • Mensajes: 20
Re:AYUDA: ruido eléctrico en entradas digitales?
« Respuesta #15 : agosto 11, 2017, 15:49:05 pm »
Hola Boris!

Finalmente creo que dimos (diste!) en la tecla: era una cuestion de software, de "formatos". Como bien decis, invocando ahora la función con BitSet(...) activo solo la salida pretendida!

Con respecto a "ruido", el sistema mejoró cuando conecté correctamente las tierras y los 10 puntos que me señalaste para corregir. Con respecto a la etapa de "potencia", actualmente estoy usando tanto los relays de salida como los sensores inductivos de forma directa, sin ningún diodo o circuito RC de protección, por lo que no parece ser un problema de ruido por las entradas y/o salidas digitales/analógicas.

Voy desarrollando este proyecto a medida que la empresa avanza con el diseño mecánico de los diferentes prototipos y te voy a seguir consultando, es muy valioso tu soporte como fabricante. Gracias por tu asistencia. Muy buena la post vent ehh !! jaja!

Saludos,

Guillermo.

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 1748
  • Soporte Técnico
Re:AYUDA: ruido eléctrico en entradas digitales?
« Respuesta #16 : agosto 11, 2017, 17:31:38 pm »
Buenísimo Guillermo!

Muchas veces pasa que un solo bit es un gran problema.

Entonces damos por solucionado este tema y seguimos por cualquier consulta  ;)

Saludos
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com

Atención: Desde el 1 de enero al 25 de enero de 2018, cerramos por vacaciones.
Tenga en cuenta para sus pedidos y/o consultas.